summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-24 01:57:28 +0200
committertv <tv@krebsco.de>2017-05-24 01:57:28 +0200
commiteae210f8ff05b7f59ab62ba161c86971dbd7f50e (patch)
tree037d7ad582303b21230a323c2e3e500ed454c911 /krebs/5pkgs/haskell
parent17df5f0c453d891b29dbb6a9d189fc8dcf88fac0 (diff)
krebs/5pkgs: move haskell stuff to a subdir
Diffstat (limited to 'krebs/5pkgs/haskell')
-rw-r--r--krebs/5pkgs/haskell/blessings.nix14
-rw-r--r--krebs/5pkgs/haskell/default.nix15
-rw-r--r--krebs/5pkgs/haskell/email-header.nix25
-rw-r--r--krebs/5pkgs/haskell/hyphenation.nix17
-rw-r--r--krebs/5pkgs/haskell/kirk.nix21
-rw-r--r--krebs/5pkgs/haskell/news.nix18
-rw-r--r--krebs/5pkgs/haskell/scanner.nix12
-rw-r--r--krebs/5pkgs/haskell/xmonad-stockholm.nix16
8 files changed, 138 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/blessings.nix b/krebs/5pkgs/haskell/blessings.nix
new file mode 100644
index 00000000..f852b4a4
--- /dev/null
+++ b/krebs/5pkgs/haskell/blessings.nix
@@ -0,0 +1,14 @@
+{ mkDerivation, base, fetchgit, stdenv }:
+mkDerivation rec {
+ pname = "blessings";
+ version = "1.1.0";
+ src = fetchgit {
+ url = http://cgit.ni.krebsco.de/blessings;
+ rev = "refs/tags/v${version}";
+ sha256 = "1k908zap3694fcxdk4bb29s54b0lhdh557y10ybjskfwnym7szn1";
+ };
+ libraryHaskellDepends = [ base ];
+ doHaddock = false;
+ # WTFPL is the true license, which is unknown to cabal.
+ license = stdenv.lib.licenses.wtfpl;
+}
diff --git a/krebs/5pkgs/haskell/default.nix b/krebs/5pkgs/haskell/default.nix
new file mode 100644
index 00000000..1120356a
--- /dev/null
+++ b/krebs/5pkgs/haskell/default.nix
@@ -0,0 +1,15 @@
+with import <stockholm/lib>;
+
+self: super:
+{
+ haskellPackages = super.haskellPackages.override {
+ overrides = self: super:
+ listToAttrs
+ (map
+ (name: nameValuePair (removeSuffix ".nix" name)
+ (self.callPackage (./. + "/${name}") {}))
+ (filter
+ (name: name != "default.nix" && !hasPrefix "." name)
+ (attrNames (readDir ./.))));
+ };
+}
diff --git a/krebs/5pkgs/haskell/email-header.nix b/krebs/5pkgs/haskell/email-header.nix
new file mode 100644
index 00000000..b5424080
--- /dev/null
+++ b/krebs/5pkgs/haskell/email-header.nix
@@ -0,0 +1,25 @@
+{ mkDerivation, attoparsec, base, base64-bytestring, bytestring
+, case-insensitive, containers, exceptions, fetchgit, QuickCheck
+, stdenv, tasty, tasty-quickcheck, text, text-icu, time
+}:
+mkDerivation {
+ pname = "email-header";
+ version = "0.3.0";
+ src = fetchgit {
+ url = "https://github.com/4z3/email-header";
+ rev = "7b179bd31192ead8afe7a0b6e34bcad4039deaa8";
+ sha256 = "12j2n3sbvzjnw99gga7kkdygm8n3qx2lh8q26ad6a53xm5whnz59";
+ };
+ buildDepends = [
+ attoparsec base base64-bytestring bytestring case-insensitive
+ containers exceptions text text-icu time
+ ];
+ testDepends = [
+ base bytestring case-insensitive containers QuickCheck tasty
+ tasty-quickcheck text time
+ ];
+ jailbreak = true;
+ homepage = "http://github.com/knrafto/email-header";
+ description = "Parsing and rendering of email and MIME headers";
+ license = stdenv.lib.licenses.bsd3;
+}
diff --git a/krebs/5pkgs/haskell/hyphenation.nix b/krebs/5pkgs/haskell/hyphenation.nix
new file mode 100644
index 00000000..6e5fe945
--- /dev/null
+++ b/krebs/5pkgs/haskell/hyphenation.nix
@@ -0,0 +1,17 @@
+# Same as upstream but with doCheck = false because doctest has wrong version.
+{ mkDerivation, base, bytestring, containers, directory
+, filepath, unordered-containers, zlib, stdenv
+}:
+mkDerivation {
+ pname = "hyphenation";
+ version = "0.6";
+ sha256 = "2f673666c18f63581422f7c6389b78b0ff754406671296a3d680d417942512f7";
+ libraryHaskellDepends = [
+ base bytestring containers unordered-containers zlib
+ ];
+ homepage = "http://github.com/ekmett/hyphenation";
+ description = "Configurable Knuth-Liang hyphenation";
+ license = stdenv.lib.licenses.bsd3;
+ hydraPlatforms = stdenv.lib.platforms.none;
+ doCheck = false;
+}
diff --git a/krebs/5pkgs/haskell/kirk.nix b/krebs/5pkgs/haskell/kirk.nix
new file mode 100644
index 00000000..073e5d50
--- /dev/null
+++ b/krebs/5pkgs/haskell/kirk.nix
@@ -0,0 +1,21 @@
+{ mkDerivation, async, base, bytestring, fetchgit, network
+, optparse-applicative, stdenv, text
+}:
+mkDerivation {
+ pname = "kirk";
+ version = "1.0.1";
+ src = fetchgit {
+ url = "http://cgit.krebsco.de/kirk";
+ sha256 = "1acsmmc485c54axpy9bd0320j18hs261vl1vdxns4n04sxzqd7k0";
+ rev = "cdf3cb373af8f9b03a9487a63eb32e0226913589";
+ };
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ base bytestring network optparse-applicative text
+ ];
+ executableHaskellDepends = [
+ async base network optparse-applicative text
+ ];
+ license = stdenv.lib.licenses.mit;
+}
diff --git a/krebs/5pkgs/haskell/news.nix b/krebs/5pkgs/haskell/news.nix
new file mode 100644
index 00000000..ba5e7a5e
--- /dev/null
+++ b/krebs/5pkgs/haskell/news.nix
@@ -0,0 +1,18 @@
+{ mkDerivation, base, bloomfilter, bytestring, feed, fetchgit, lens
+, stdenv, wreq
+}:
+mkDerivation {
+ pname = "news";
+ version = "1.0.0";
+ src = fetchgit {
+ url = "http://cgit.lassul.us/news";
+ sha256 = "1n3ffr2a5irr5aly0y7qsafag3kxvyyh077ayk0vdwbd0s9hvnjs";
+ rev = "c3eb2c0a1a34fc41e18d0bc99b1c4dc73aa6eb20";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ base bloomfilter bytestring feed lens wreq
+ ];
+ license = stdenv.lib.licenses.mit;
+}
diff --git a/krebs/5pkgs/haskell/scanner.nix b/krebs/5pkgs/haskell/scanner.nix
new file mode 100644
index 00000000..071fd757
--- /dev/null
+++ b/krebs/5pkgs/haskell/scanner.nix
@@ -0,0 +1,12 @@
+{ mkDerivation, base, fetchgit, stdenv }:
+mkDerivation {
+ pname = "scanner";
+ version = "1.0.0";
+ src = fetchgit {
+ url = http://cgit.ni.krebsco.de/scanner;
+ rev = "7f091a3bc152ad3974a1873b460fa1759bf8dcad";
+ sha256 = "1lgl158axczsm4fx53fyq1d4116v91jsx4dbz66ka4k1ljqrmhgn";
+ };
+ libraryHaskellDepends = [ base ];
+ license = stdenv.lib.licenses.wtfpl;
+}
diff --git a/krebs/5pkgs/haskell/xmonad-stockholm.nix b/krebs/5pkgs/haskell/xmonad-stockholm.nix
new file mode 100644
index 00000000..bf19e7d6
--- /dev/null
+++ b/krebs/5pkgs/haskell/xmonad-stockholm.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, base, containers, fetchgit, stdenv, X11, X11-xshape
+, xmonad, xmonad-contrib
+}:
+mkDerivation {
+ pname = "xmonad-stockholm";
+ version = "1.1.0";
+ src = fetchgit {
+ url = http://cgit.ni.krebsco.de/xmonad-stockholm;
+ rev = "179d29fd4c765dee698058ef63295331ac603639";
+ sha256 = "0c6mj68xsxxr4j8adkzhjszi7bg6cpisrsmqn587a16sblpbrnkj";
+ };
+ libraryHaskellDepends = [
+ base containers X11 X11-xshape xmonad xmonad-contrib
+ ];
+ license = stdenv.lib.licenses.mit;
+}