summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/kirk.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/kirk.nix')
-rw-r--r--krebs/5pkgs/haskell/kirk.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/kirk.nix b/krebs/5pkgs/haskell/kirk.nix
new file mode 100644
index 00000000..073e5d50
--- /dev/null
+++ b/krebs/5pkgs/haskell/kirk.nix
@@ -0,0 +1,21 @@
+{ mkDerivation, async, base, bytestring, fetchgit, network
+, optparse-applicative, stdenv, text
+}:
+mkDerivation {
+ pname = "kirk";
+ version = "1.0.1";
+ src = fetchgit {
+ url = "http://cgit.krebsco.de/kirk";
+ sha256 = "1acsmmc485c54axpy9bd0320j18hs261vl1vdxns4n04sxzqd7k0";
+ rev = "cdf3cb373af8f9b03a9487a63eb32e0226913589";
+ };
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ base bytestring network optparse-applicative text
+ ];
+ executableHaskellDepends = [
+ async base network optparse-applicative text
+ ];
+ license = stdenv.lib.licenses.mit;
+}