summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/hyphenation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/hyphenation.nix')
-rw-r--r--krebs/5pkgs/haskell/hyphenation.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/hyphenation.nix b/krebs/5pkgs/haskell/hyphenation.nix
new file mode 100644
index 00000000..6e5fe945
--- /dev/null
+++ b/krebs/5pkgs/haskell/hyphenation.nix
@@ -0,0 +1,17 @@
+# Same as upstream but with doCheck = false because doctest has wrong version.
+{ mkDerivation, base, bytestring, containers, directory
+, filepath, unordered-containers, zlib, stdenv
+}:
+mkDerivation {
+ pname = "hyphenation";
+ version = "0.6";
+ sha256 = "2f673666c18f63581422f7c6389b78b0ff754406671296a3d680d417942512f7";
+ libraryHaskellDepends = [
+ base bytestring containers unordered-containers zlib
+ ];
+ homepage = "http://github.com/ekmett/hyphenation";
+ description = "Configurable Knuth-Liang hyphenation";
+ license = stdenv.lib.licenses.bsd3;
+ hydraPlatforms = stdenv.lib.platforms.none;
+ doCheck = false;
+}