summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/blessings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/blessings.nix')
-rw-r--r--krebs/5pkgs/haskell/blessings.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/blessings.nix b/krebs/5pkgs/haskell/blessings.nix
new file mode 100644
index 00000000..f852b4a4
--- /dev/null
+++ b/krebs/5pkgs/haskell/blessings.nix
@@ -0,0 +1,14 @@
+{ mkDerivation, base, fetchgit, stdenv }:
+mkDerivation rec {
+ pname = "blessings";
+ version = "1.1.0";
+ src = fetchgit {
+ url = http://cgit.ni.krebsco.de/blessings;
+ rev = "refs/tags/v${version}";
+ sha256 = "1k908zap3694fcxdk4bb29s54b0lhdh557y10ybjskfwnym7szn1";
+ };
+ libraryHaskellDepends = [ base ];
+ doHaddock = false;
+ # WTFPL is the true license, which is unknown to cabal.
+ license = stdenv.lib.licenses.wtfpl;
+}