summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/blessings.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-24 01:57:28 +0200
committertv <tv@krebsco.de>2017-05-24 01:57:28 +0200
commiteae210f8ff05b7f59ab62ba161c86971dbd7f50e (patch)
tree037d7ad582303b21230a323c2e3e500ed454c911 /krebs/5pkgs/haskell/blessings.nix
parent17df5f0c453d891b29dbb6a9d189fc8dcf88fac0 (diff)
krebs/5pkgs: move haskell stuff to a subdir
Diffstat (limited to 'krebs/5pkgs/haskell/blessings.nix')
-rw-r--r--krebs/5pkgs/haskell/blessings.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/blessings.nix b/krebs/5pkgs/haskell/blessings.nix
new file mode 100644
index 00000000..f852b4a4
--- /dev/null
+++ b/krebs/5pkgs/haskell/blessings.nix
@@ -0,0 +1,14 @@
+{ mkDerivation, base, fetchgit, stdenv }:
+mkDerivation rec {
+ pname = "blessings";
+ version = "1.1.0";
+ src = fetchgit {
+ url = http://cgit.ni.krebsco.de/blessings;
+ rev = "refs/tags/v${version}";
+ sha256 = "1k908zap3694fcxdk4bb29s54b0lhdh557y10ybjskfwnym7szn1";
+ };
+ libraryHaskellDepends = [ base ];
+ doHaddock = false;
+ # WTFPL is the true license, which is unknown to cabal.
+ license = stdenv.lib.licenses.wtfpl;
+}