summaryrefslogtreecommitdiffstats
path: root/lass/2configs/buildbot-standalone.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-11-11 13:44:55 +0100
committermakefu <github@syntax-fehler.de>2016-11-11 13:44:55 +0100
commit4d7f0e6c5bcd8b586711ad2394fac73ebbd3312d (patch)
treea21db730913e0915ec1e319af70673e7cf4e5001 /lass/2configs/buildbot-standalone.nix
parent6c092cd20ca256b1cefa92aa779380cdb71c1313 (diff)
parent0e13a4e2373d891e6a895e4b6ad2b42da028ba12 (diff)
Merge remote-tracking branch 'prism/lassulus'
Diffstat (limited to 'lass/2configs/buildbot-standalone.nix')
-rw-r--r--lass/2configs/buildbot-standalone.nix53
1 files changed, 1 insertions, 52 deletions
diff --git a/lass/2configs/buildbot-standalone.nix b/lass/2configs/buildbot-standalone.nix
index 00911cf9..cf3354fd 100644
--- a/lass/2configs/buildbot-standalone.nix
+++ b/lass/2configs/buildbot-standalone.nix
@@ -25,20 +25,6 @@ in {
pollinterval=120))
'';
scheduler = {
- force-scheduler = ''
- sched.append(schedulers.ForceScheduler(
- name="force",
- builderNames=["fast-tests"]))
- '';
- fast-tests-scheduler = ''
- # test everything real quick
- sched.append(schedulers.SingleBranchScheduler(
- ## all branches
- change_filter=util.ChangeFilter(branch_re=".*"),
- treeStableTimer=10,
- name="fast-all-branches",
- builderNames=["fast-tests"]))
- '';
build-scheduler = ''
# build all hosts
sched.append(schedulers.SingleBranchScheduler(
@@ -113,43 +99,6 @@ in {
'';
- fast-tests = ''
- f = util.BuildFactory()
- f.addStep(grab_repo)
- for i in [ "mors", "uriel", "shodan", "helios", "cloudkrebs", "echelon", "dishfire", "prism" ]:
- addShell(f,name="build-{}".format(i),env=env_lass,
- command=nixshell + \
- ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
- make \
- test \
- target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
- method=eval \
- system={}".format(i)])
-
- for i in [ "x", "wry", "vbob", "wbob", "shoney" ]:
- addShell(f,name="build-{}".format(i),env=env_makefu,
- command=nixshell + \
- ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
- make \
- test \
- target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
- method=eval \
- system={}".format(i)])
-
- for i in [ "test-minimal-deploy", "test-all-krebs-modules", "wolf" ]:
- addShell(f,name="build-{}".format(i),env=env_shared,
- command=nixshell + \
- ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
- make \
- test \
- target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
- method=eval \
- system={}".format(i)])
-
- bu.append(util.BuilderConfig(name="fast-tests",
- slavenames=slavenames,
- factory=f))
- '';
build-pkgs = ''
f = util.BuildFactory()
f.addStep(grab_repo)
@@ -212,7 +161,7 @@ in {
irc = {
enable = true;
nick = "buildbot-lass";
- server = "cd.retiolum";
+ server = "ni.r";
channels = [ { channels = "retiolum"; } ];
allowForce = true;
};