summaryrefslogtreecommitdiffstats
path: root/lass/2configs/buildbot-standalone.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-11-11 08:49:37 +0100
committertv <tv@krebsco.de>2016-11-11 08:49:37 +0100
commit0e13a4e2373d891e6a895e4b6ad2b42da028ba12 (patch)
tree1d8ca040ab86b462d6e3fd283997d56177fa4b33 /lass/2configs/buildbot-standalone.nix
parentb837dec290e54f532cd5539c93a663ba11f68c54 (diff)
parente6c7b13f5990d96e269ee12b9bf6b15bfa7d5b82 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/2configs/buildbot-standalone.nix')
-rw-r--r--lass/2configs/buildbot-standalone.nix51
1 files changed, 0 insertions, 51 deletions
diff --git a/lass/2configs/buildbot-standalone.nix b/lass/2configs/buildbot-standalone.nix
index d6dc1b22..4397bf78 100644
--- a/lass/2configs/buildbot-standalone.nix
+++ b/lass/2configs/buildbot-standalone.nix
@@ -25,20 +25,6 @@ in {
pollinterval=120))
'';
scheduler = {
- force-scheduler = ''
- sched.append(schedulers.ForceScheduler(
- name="force",
- builderNames=["fast-tests"]))
- '';
- fast-tests-scheduler = ''
- # test everything real quick
- sched.append(schedulers.SingleBranchScheduler(
- ## all branches
- change_filter=util.ChangeFilter(branch_re=".*"),
- treeStableTimer=10,
- name="fast-all-branches",
- builderNames=["fast-tests"]))
- '';
build-scheduler = ''
# build all hosts
sched.append(schedulers.SingleBranchScheduler(
@@ -113,43 +99,6 @@ in {
'';
- fast-tests = ''
- f = util.BuildFactory()
- f.addStep(grab_repo)
- for i in [ "mors", "uriel", "shodan", "helios", "cloudkrebs", "echelon", "dishfire", "prism" ]:
- addShell(f,name="build-{}".format(i),env=env_lass,
- command=nixshell + \
- ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
- make \
- test \
- target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
- method=eval \
- system={}".format(i)])
-
- for i in [ "x", "wry", "vbob", "wbob", "shoney" ]:
- addShell(f,name="build-{}".format(i),env=env_makefu,
- command=nixshell + \
- ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
- make \
- test \
- target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
- method=eval \
- system={}".format(i)])
-
- for i in [ "test-minimal-deploy", "test-all-krebs-modules", "wolf" ]:
- addShell(f,name="build-{}".format(i),env=env_shared,
- command=nixshell + \
- ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
- make \
- test \
- target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
- method=eval \
- system={}".format(i)])
-
- bu.append(util.BuilderConfig(name="fast-tests",
- slavenames=slavenames,
- factory=f))
- '';
build-pkgs = ''
f = util.BuildFactory()
f.addStep(grab_repo)