summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/rpi/WiringPi
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/rpi/WiringPi')
-rw-r--r--tv/5pkgs/rpi/WiringPi/default.nix61
-rw-r--r--tv/5pkgs/rpi/WiringPi/src.json6
2 files changed, 0 insertions, 67 deletions
diff --git a/tv/5pkgs/rpi/WiringPi/default.nix b/tv/5pkgs/rpi/WiringPi/default.nix
deleted file mode 100644
index 40fcaeae..00000000
--- a/tv/5pkgs/rpi/WiringPi/default.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ fetchFromGitHub, lib, runCommand, stdenv }:
-
-let
- generic = name: extraAttrs:
- stdenv.mkDerivation ({
- pname = "WiringPi-${name}";
- version = "2020-09-14";
-
- src = fetchFromGitHub (lib.importJSON ./src.json);
-
- buildPhase = ''
- runHook postBuild
-
- make -C ${name} all
-
- runHook preBuild
- '';
-
- installPhase = ''
- runHook preInstall
-
- export DESTDIR=$out
- export PREFIX=
- export LDCONFIG=true
-
- make -C ${name} install
-
- runHook postInstall
- '';
- } // extraAttrs);
-
- fakeutils = runCommand "fakeutils-1.0" {} /* sh */ ''
- mkdir -p $out/bin
- for name in chown chmod; do
- touch $out/bin/$name
- chmod +x $out/bin/$name
- done
- '';
-in
-
-rec {
- wiringPi = generic "wiringPi" {};
- wiringPiDev = generic "devLib" {
- buildInputs = [
- wiringPi
- ];
- };
- gpio = generic "gpio" {
- preInstall = ''
- # fakeutils cannot be buildInputs because they have to override existing
- # executables and therefore need to be prepended to the search path.
- PATH=${fakeutils}/bin:$PATH
-
- mkdir -p $out/bin
- '';
- buildInputs = [
- wiringPi
- wiringPiDev
- ];
- };
-}
diff --git a/tv/5pkgs/rpi/WiringPi/src.json b/tv/5pkgs/rpi/WiringPi/src.json
deleted file mode 100644
index edf4e827..00000000
--- a/tv/5pkgs/rpi/WiringPi/src.json
+++ /dev/null
@@ -1,6 +0,0 @@
-{
- "owner": "WiringPi",
- "repo": "WiringPi",
- "rev": "5c6bab7d4279e8c0cc890984eaa1a69ff3af1c99",
- "sha256": "1jlx7lb3ybwv06b2dpmsr718d0xj85awl1dgdqc607k50kk25mjb"
-}