summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/rpi
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/rpi')
-rw-r--r--tv/5pkgs/rpi/433Utils/RPi_utils.codesend.codestring.patch24
-rw-r--r--tv/5pkgs/rpi/433Utils/default.nix42
-rw-r--r--tv/5pkgs/rpi/433Utils/rc-switch.protocols.patch10
-rw-r--r--tv/5pkgs/rpi/433Utils/src.json7
-rw-r--r--tv/5pkgs/rpi/WiringPi/default.nix61
-rw-r--r--tv/5pkgs/rpi/WiringPi/src.json6
-rw-r--r--tv/5pkgs/rpi/default.nix9
7 files changed, 0 insertions, 159 deletions
diff --git a/tv/5pkgs/rpi/433Utils/RPi_utils.codesend.codestring.patch b/tv/5pkgs/rpi/433Utils/RPi_utils.codesend.codestring.patch
deleted file mode 100644
index 447e42f1..00000000
--- a/tv/5pkgs/rpi/433Utils/RPi_utils.codesend.codestring.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/RPi_utils/codesend.cpp
-+++ b/RPi_utils/codesend.cpp
-@@ -40,18 +40,18 @@ int main(int argc, char *argv[]) {
- }
-
- // Change protocol and pulse length accroding to parameters
-- int code = atoi(argv[1]);
-+ const char *code = argv[1];
- if (argc >= 3) protocol = atoi(argv[2]);
- if (argc >= 4) pulseLength = atoi(argv[3]);
-
- if (wiringPiSetup () == -1) return 1;
-- printf("sending code[%i]\n", code);
-+ printf("sending code[%s]\n", code);
- RCSwitch mySwitch = RCSwitch();
- if (protocol != 0) mySwitch.setProtocol(protocol);
- if (pulseLength != 0) mySwitch.setPulseLength(pulseLength);
- mySwitch.enableTransmit(PIN);
-
-- mySwitch.send(code, 24);
-+ mySwitch.send(code);
-
- return 0;
-
diff --git a/tv/5pkgs/rpi/433Utils/default.nix b/tv/5pkgs/rpi/433Utils/default.nix
deleted file mode 100644
index 136e3dbc..00000000
--- a/tv/5pkgs/rpi/433Utils/default.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{ fetchFromGitHub, lib, stdenv
-, wiringPi ? WiringPi.wiringPi
-, wiringPiDev ? WiringPi.wiringPiDev
-, WiringPi ? rpiPackages.WiringPi
-, rpiPackages
-}:
-
-stdenv.mkDerivation {
- pname = "433Utils-RPi_utils";
- version = "2018-06-07";
-
- src = fetchFromGitHub (lib.importJSON ./src.json);
-
- patches = [
- ./rc-switch.protocols.patch
- ./RPi_utils.codesend.codestring.patch
- ];
-
- buildPhase = ''
- runHook postBuild
-
- make -C RPi_utils
-
- runHook preBuild
- '';
-
- buildInputs = [
- wiringPi
- wiringPiDev
- ];
-
- installPhase = ''
- runHook preInstall
-
- mkdir -p $out/bin
- for name in send codesend RFSniffer; do
- cp RPi_utils/$name $out/bin/
- done
-
- runHook postInstall
- '';
-}
diff --git a/tv/5pkgs/rpi/433Utils/rc-switch.protocols.patch b/tv/5pkgs/rpi/433Utils/rc-switch.protocols.patch
deleted file mode 100644
index 41304ef8..00000000
--- a/tv/5pkgs/rpi/433Utils/rc-switch.protocols.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/rc-switch/RCSwitch.cpp
-+++ b/rc-switch/RCSwitch.cpp
-@@ -78,6 +78,7 @@ static const RCSwitch::Protocol PROGMEM proto[] = {
- { 100, { 30, 71 }, { 4, 11 }, { 9, 6 } }, // protocol 3
- { 380, { 1, 6 }, { 1, 3 }, { 3, 1 } }, // protocol 4
- { 500, { 6, 14 }, { 1, 2 }, { 2, 1 } }, // protocol 5
-+ { 136, { 1, 31 }, { 1, 3 }, { 3, 1 } }, // protocol 6
- };
-
- enum {
diff --git a/tv/5pkgs/rpi/433Utils/src.json b/tv/5pkgs/rpi/433Utils/src.json
deleted file mode 100644
index 3cf23278..00000000
--- a/tv/5pkgs/rpi/433Utils/src.json
+++ /dev/null
@@ -1,7 +0,0 @@
-{
- "owner": "ninjablocks",
- "repo": "433Utils",
- "rev": "31c0ea4e158287595a6f6116b6151e72691e1839",
- "sha256": "04r2qlkdsz46qgpnbizrfccz1i0qlkb1iqz0jzyq4fzvksqp9dg1",
- "fetchSubmodules": true
-} \ No newline at end of file
diff --git a/tv/5pkgs/rpi/WiringPi/default.nix b/tv/5pkgs/rpi/WiringPi/default.nix
deleted file mode 100644
index 40fcaeae..00000000
--- a/tv/5pkgs/rpi/WiringPi/default.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ fetchFromGitHub, lib, runCommand, stdenv }:
-
-let
- generic = name: extraAttrs:
- stdenv.mkDerivation ({
- pname = "WiringPi-${name}";
- version = "2020-09-14";
-
- src = fetchFromGitHub (lib.importJSON ./src.json);
-
- buildPhase = ''
- runHook postBuild
-
- make -C ${name} all
-
- runHook preBuild
- '';
-
- installPhase = ''
- runHook preInstall
-
- export DESTDIR=$out
- export PREFIX=
- export LDCONFIG=true
-
- make -C ${name} install
-
- runHook postInstall
- '';
- } // extraAttrs);
-
- fakeutils = runCommand "fakeutils-1.0" {} /* sh */ ''
- mkdir -p $out/bin
- for name in chown chmod; do
- touch $out/bin/$name
- chmod +x $out/bin/$name
- done
- '';
-in
-
-rec {
- wiringPi = generic "wiringPi" {};
- wiringPiDev = generic "devLib" {
- buildInputs = [
- wiringPi
- ];
- };
- gpio = generic "gpio" {
- preInstall = ''
- # fakeutils cannot be buildInputs because they have to override existing
- # executables and therefore need to be prepended to the search path.
- PATH=${fakeutils}/bin:$PATH
-
- mkdir -p $out/bin
- '';
- buildInputs = [
- wiringPi
- wiringPiDev
- ];
- };
-}
diff --git a/tv/5pkgs/rpi/WiringPi/src.json b/tv/5pkgs/rpi/WiringPi/src.json
deleted file mode 100644
index edf4e827..00000000
--- a/tv/5pkgs/rpi/WiringPi/src.json
+++ /dev/null
@@ -1,6 +0,0 @@
-{
- "owner": "WiringPi",
- "repo": "WiringPi",
- "rev": "5c6bab7d4279e8c0cc890984eaa1a69ff3af1c99",
- "sha256": "1jlx7lb3ybwv06b2dpmsr718d0xj85awl1dgdqc607k50kk25mjb"
-}
diff --git a/tv/5pkgs/rpi/default.nix b/tv/5pkgs/rpi/default.nix
deleted file mode 100644
index f0ac47f6..00000000
--- a/tv/5pkgs/rpi/default.nix
+++ /dev/null
@@ -1,9 +0,0 @@
-let
- lib = import <stockholm/lib>;
-in
-
-self: super:
-
-{
- rpiPackages = lib.mapNixDir (path: self.callPackage path {}) ./.;
-}