summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/charybdis
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/charybdis')
-rw-r--r--tv/5pkgs/charybdis/default.nix34
-rw-r--r--tv/5pkgs/charybdis/remove-setenv.patch12
2 files changed, 46 insertions, 0 deletions
diff --git a/tv/5pkgs/charybdis/default.nix b/tv/5pkgs/charybdis/default.nix
new file mode 100644
index 00000000..f3e6be40
--- /dev/null
+++ b/tv/5pkgs/charybdis/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchgit, bison, flex, openssl }:
+
+stdenv.mkDerivation rec {
+ name = "charybdis-3.5.0-rc1";
+
+ src = fetchgit {
+ url = "https://github.com/atheme/charybdis.git";
+ rev = "61815bf9324e872f51255e09fe37a8c595f94a60";
+ sha256 = "0zsd6xk2cnspc1cvryy2296p3ix4hwjd9k24wmgbh5wzks0wahwy";
+ };
+
+ patches = [
+ ./remove-setenv.patch
+ ];
+
+ configureFlags = [
+ "--enable-epoll"
+ "--enable-ipv6"
+ "--enable-openssl=${openssl}"
+ "--enable-small-net"
+ "--with-program-prefix=charybdis-"
+ "--sysconfdir=/tmp"
+ ];
+
+ buildInputs = [ bison flex openssl ];
+
+ meta = {
+ description = "An extremely scalable ircd with some cooperation with the ratbox and ircu guys";
+ homepage = https://github.com/atheme/charybdis;
+ license = stdenv.lib.licenses.gpl2;
+ maintainers = [ stdenv.lib.maintainers.lassulus ];
+ platforms = stdenv.lib.platforms.linux;
+ };
+}
diff --git a/tv/5pkgs/charybdis/remove-setenv.patch b/tv/5pkgs/charybdis/remove-setenv.patch
new file mode 100644
index 00000000..bbaf95e1
--- /dev/null
+++ b/tv/5pkgs/charybdis/remove-setenv.patch
@@ -0,0 +1,12 @@
+diff --git a/src/bandbi.c b/src/bandbi.c
+index 03dd907..3698e85 100644
+--- a/src/bandbi.c
++++ b/src/bandbi.c
+@@ -82,7 +82,6 @@ start_bandb(void)
+ const char *suffix = "";
+ #endif
+
+- rb_setenv("BANDB_DBPATH", PKGLOCALSTATEDIR "/ban.db", 1);
+ if(bandb_path == NULL)
+ {
+ rb_snprintf(fullpath, sizeof(fullpath), "%s/bandb%s", PKGLIBEXECDIR, suffix);