summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/charybdis/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/charybdis/default.nix')
-rw-r--r--tv/5pkgs/charybdis/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/tv/5pkgs/charybdis/default.nix b/tv/5pkgs/charybdis/default.nix
new file mode 100644
index 00000000..f3e6be40
--- /dev/null
+++ b/tv/5pkgs/charybdis/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchgit, bison, flex, openssl }:
+
+stdenv.mkDerivation rec {
+ name = "charybdis-3.5.0-rc1";
+
+ src = fetchgit {
+ url = "https://github.com/atheme/charybdis.git";
+ rev = "61815bf9324e872f51255e09fe37a8c595f94a60";
+ sha256 = "0zsd6xk2cnspc1cvryy2296p3ix4hwjd9k24wmgbh5wzks0wahwy";
+ };
+
+ patches = [
+ ./remove-setenv.patch
+ ];
+
+ configureFlags = [
+ "--enable-epoll"
+ "--enable-ipv6"
+ "--enable-openssl=${openssl}"
+ "--enable-small-net"
+ "--with-program-prefix=charybdis-"
+ "--sysconfdir=/tmp"
+ ];
+
+ buildInputs = [ bison flex openssl ];
+
+ meta = {
+ description = "An extremely scalable ircd with some cooperation with the ratbox and ircu guys";
+ homepage = https://github.com/atheme/charybdis;
+ license = stdenv.lib.licenses.gpl2;
+ maintainers = [ stdenv.lib.maintainers.lassulus ];
+ platforms = stdenv.lib.platforms.linux;
+ };
+}