summaryrefslogtreecommitdiffstats
path: root/tv/3modules/hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/3modules/hw.nix')
-rw-r--r--tv/3modules/hw.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tv/3modules/hw.nix b/tv/3modules/hw.nix
new file mode 100644
index 00000000..6eb722d2
--- /dev/null
+++ b/tv/3modules/hw.nix
@@ -0,0 +1,16 @@
+let
+ lib = import <stockholm/lib>;
+ local.types.screen = lib.types.submodule {
+ options.width = lib.mkOption {
+ type = lib.types.uint;
+ };
+ options.height = lib.mkOption {
+ type = lib.types.uint;
+ };
+ };
+in {
+ options.tv.hw.screens = lib.mkOption {
+ type = lib.types.attrsOf local.types.screen;
+ default = {};
+ };
+}