summaryrefslogtreecommitdiffstats
path: root/tv/3modules/hw.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-02-15 13:52:20 +0100
committertv <tv@krebsco.de>2021-02-15 13:52:20 +0100
commitd2edb22d9f975959fc21a19f4e9da4a591d2b2a5 (patch)
treedbccc8ccf1e3155ba4ae360e97e131b388d75ce6 /tv/3modules/hw.nix
parent824e5f02a1b921d086b8f33f3dce16588ad51ac0 (diff)
tv.hw.screens: init
Diffstat (limited to 'tv/3modules/hw.nix')
-rw-r--r--tv/3modules/hw.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tv/3modules/hw.nix b/tv/3modules/hw.nix
new file mode 100644
index 00000000..6eb722d2
--- /dev/null
+++ b/tv/3modules/hw.nix
@@ -0,0 +1,16 @@
+let
+ lib = import <stockholm/lib>;
+ local.types.screen = lib.types.submodule {
+ options.width = lib.mkOption {
+ type = lib.types.uint;
+ };
+ options.height = lib.mkOption {
+ type = lib.types.uint;
+ };
+ };
+in {
+ options.tv.hw.screens = lib.mkOption {
+ type = lib.types.attrsOf local.types.screen;
+ default = {};
+ };
+}