summaryrefslogtreecommitdiffstats
path: root/tv/2configs/sshd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/sshd.nix')
-rw-r--r--tv/2configs/sshd.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tv/2configs/sshd.nix b/tv/2configs/sshd.nix
new file mode 100644
index 00000000..943f32fe
--- /dev/null
+++ b/tv/2configs/sshd.nix
@@ -0,0 +1,16 @@
+{ config, lib, pkgs, ... }:
+
+with config.krebs.lib;
+
+{
+ services.openssh = {
+ enable = true;
+ hostKeys = [
+ {
+ type = "ed25519";
+ path = "/etc/ssh/ssh_host_ed25519_key";
+ }
+ ];
+ };
+ tv.iptables.input-internet-accept-tcp = singleton "ssh";
+}