summaryrefslogtreecommitdiffstats
path: root/tv/2configs/sshd.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-07-23 13:11:50 +0200
committertv <tv@krebsco.de>2016-07-23 13:11:50 +0200
commit268303de888591f4b98dc610f89707cd3cfe3ef7 (patch)
tree4cabdbf57d27aa02e38cbf6b10d649e5d45fe196 /tv/2configs/sshd.nix
parentce32d546deb0bab0fc664d65abe458fee34a5123 (diff)
tv sshd: init
Diffstat (limited to 'tv/2configs/sshd.nix')
-rw-r--r--tv/2configs/sshd.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tv/2configs/sshd.nix b/tv/2configs/sshd.nix
new file mode 100644
index 00000000..943f32fe
--- /dev/null
+++ b/tv/2configs/sshd.nix
@@ -0,0 +1,16 @@
+{ config, lib, pkgs, ... }:
+
+with config.krebs.lib;
+
+{
+ services.openssh = {
+ enable = true;
+ hostKeys = [
+ {
+ type = "ed25519";
+ path = "/etc/ssh/ssh_host_ed25519_key";
+ }
+ ];
+ };
+ tv.iptables.input-internet-accept-tcp = singleton "ssh";
+}