summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/nginx/options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/tv/nginx/options.nix')
-rw-r--r--old/modules/tv/nginx/options.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/old/modules/tv/nginx/options.nix b/old/modules/tv/nginx/options.nix
new file mode 100644
index 00000000..ddfb3804
--- /dev/null
+++ b/old/modules/tv/nginx/options.nix
@@ -0,0 +1,21 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types;
+in
+
+{
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Enable nginx.";
+ };
+
+ retiolum-locations = mkOption {
+ type = with types; listOf (attrsOf str);
+ default = [];
+ description = ''
+ TODO
+ '';
+ };
+}