summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/nginx/options.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/tv/nginx/options.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'old/modules/tv/nginx/options.nix')
-rw-r--r--old/modules/tv/nginx/options.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/old/modules/tv/nginx/options.nix b/old/modules/tv/nginx/options.nix
new file mode 100644
index 00000000..ddfb3804
--- /dev/null
+++ b/old/modules/tv/nginx/options.nix
@@ -0,0 +1,21 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types;
+in
+
+{
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Enable nginx.";
+ };
+
+ retiolum-locations = mkOption {
+ type = with types; listOf (attrsOf str);
+ default = [];
+ description = ''
+ TODO
+ '';
+ };
+}