summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/games.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/lass/games.nix')
-rw-r--r--old/modules/lass/games.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/old/modules/lass/games.nix b/old/modules/lass/games.nix
new file mode 100644
index 00000000..6043a875
--- /dev/null
+++ b/old/modules/lass/games.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+
+let
+ mainUser = config.users.extraUsers.mainUser;
+
+in {
+ environment.systemPackages = with pkgs; [
+ dwarf_fortress
+ ];
+
+ users.extraUsers = {
+ games = {
+ name = "games";
+ description = "user playing games";
+ home = "/home/games";
+ extraGroups = [ "audio" "video" "input" ];
+ createHome = true;
+ useDefaultShell = true;
+ };
+ };
+
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(games) NOPASSWD: ALL
+ '';
+}