summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/games.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/lass/games.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'old/modules/lass/games.nix')
-rw-r--r--old/modules/lass/games.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/old/modules/lass/games.nix b/old/modules/lass/games.nix
new file mode 100644
index 00000000..6043a875
--- /dev/null
+++ b/old/modules/lass/games.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+
+let
+ mainUser = config.users.extraUsers.mainUser;
+
+in {
+ environment.systemPackages = with pkgs; [
+ dwarf_fortress
+ ];
+
+ users.extraUsers = {
+ games = {
+ name = "games";
+ description = "user playing games";
+ home = "/home/games";
+ extraGroups = [ "audio" "video" "input" ];
+ createHome = true;
+ useDefaultShell = true;
+ };
+ };
+
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(games) NOPASSWD: ALL
+ '';
+}