summaryrefslogtreecommitdiffstats
path: root/old/modules/common/sshkeys.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/common/sshkeys.nix')
-rw-r--r--old/modules/common/sshkeys.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/old/modules/common/sshkeys.nix b/old/modules/common/sshkeys.nix
new file mode 100644
index 00000000..5f1c6066
--- /dev/null
+++ b/old/modules/common/sshkeys.nix
@@ -0,0 +1,26 @@
+{ lib, ... }:
+
+with lib;
+
+{
+ options = {
+ sshKeys = mkOption {
+ type = types.attrsOf (types.submodule (
+ { config, ... }:
+ {
+ options = {
+ pub = mkOption {
+ type = types.str;
+ description = "Public part of the ssh key.";
+ };
+
+ priv = mkOption {
+ type = types.str;
+ description = "Private part of the ssh key.";
+ };
+ };
+ }));
+ description = "collection of ssh-keys";
+ };
+ };
+}