summaryrefslogtreecommitdiffstats
path: root/old/modules/common/sshkeys.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/common/sshkeys.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'old/modules/common/sshkeys.nix')
-rw-r--r--old/modules/common/sshkeys.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/old/modules/common/sshkeys.nix b/old/modules/common/sshkeys.nix
new file mode 100644
index 00000000..5f1c6066
--- /dev/null
+++ b/old/modules/common/sshkeys.nix
@@ -0,0 +1,26 @@
+{ lib, ... }:
+
+with lib;
+
+{
+ options = {
+ sshKeys = mkOption {
+ type = types.attrsOf (types.submodule (
+ { config, ... }:
+ {
+ options = {
+ pub = mkOption {
+ type = types.str;
+ description = "Public part of the ssh key.";
+ };
+
+ priv = mkOption {
+ type = types.str;
+ description = "Private part of the ssh key.";
+ };
+ };
+ }));
+ description = "collection of ssh-keys";
+ };
+ };
+}