summaryrefslogtreecommitdiffstats
path: root/mb/2configs/headless.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mb/2configs/headless.nix')
-rw-r--r--mb/2configs/headless.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/mb/2configs/headless.nix b/mb/2configs/headless.nix
new file mode 100644
index 00000000..46a9b6a7
--- /dev/null
+++ b/mb/2configs/headless.nix
@@ -0,0 +1,25 @@
+# Common configuration for headless machines (e.g., Amazon EC2
+# instances).
+
+{ lib, ... }:
+
+with lib;
+
+{
+ boot.vesa = false;
+
+ # Don't start a tty on the serial consoles.
+ systemd.services."serial-getty@ttyS0".enable = false;
+ systemd.services."serial-getty@hvc0".enable = false;
+ systemd.services."getty@tty1".enable = false;
+ systemd.services."autovt@".enable = false;
+
+ # Since we can't manually respond to a panic, just reboot.
+ boot.kernelParams = [ "panic=1" "boot.panic_on_fail" ];
+
+ # Don't allow emergency mode, because we don't have a console.
+ systemd.enableEmergencyMode = false;
+
+ # Being headless, we don't need a GRUB splash image.
+ boot.loader.grub.splashImage = null;
+}