summaryrefslogtreecommitdiffstats
path: root/mb/2configs/headless.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-07-16 19:06:14 +0200
committerjeschli <jeschli@gmail.com>2019-07-16 19:06:14 +0200
commitcd4f0290ed091cdae9b5d8526f4387b54e2c42dc (patch)
tree1db65f278382130f52da18aaafbc31d7d8e52376 /mb/2configs/headless.nix
parentecb6c5fe8784de4aeceef437368cb501e1d659ce (diff)
parent3f0435e89cbdccf8ad8ab351cc3eab349c427e60 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'mb/2configs/headless.nix')
-rw-r--r--mb/2configs/headless.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/mb/2configs/headless.nix b/mb/2configs/headless.nix
new file mode 100644
index 00000000..46a9b6a7
--- /dev/null
+++ b/mb/2configs/headless.nix
@@ -0,0 +1,25 @@
+# Common configuration for headless machines (e.g., Amazon EC2
+# instances).
+
+{ lib, ... }:
+
+with lib;
+
+{
+ boot.vesa = false;
+
+ # Don't start a tty on the serial consoles.
+ systemd.services."serial-getty@ttyS0".enable = false;
+ systemd.services."serial-getty@hvc0".enable = false;
+ systemd.services."getty@tty1".enable = false;
+ systemd.services."autovt@".enable = false;
+
+ # Since we can't manually respond to a panic, just reboot.
+ boot.kernelParams = [ "panic=1" "boot.panic_on_fail" ];
+
+ # Don't allow emergency mode, because we don't have a console.
+ systemd.enableEmergencyMode = false;
+
+ # Being headless, we don't need a GRUB splash image.
+ boot.loader.grub.splashImage = null;
+}