summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/uhub/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/uhub/default.nix')
-rw-r--r--makefu/5pkgs/uhub/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/makefu/5pkgs/uhub/default.nix b/makefu/5pkgs/uhub/default.nix
index 66dfebc3..e0ee035e 100644
--- a/makefu/5pkgs/uhub/default.nix
+++ b/makefu/5pkgs/uhub/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchpatch, fetchFromGitHub, cmake, openssl, sqlite, pkgconfig, systemd
+{ stdenv, lib, fetchpatch, fetchFromGitHub, cmake, openssl, sqlite, pkgconfig, systemd
, tlsSupport ? false }:
assert tlsSupport -> openssl != null;
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
};
nativeBuildInputs = [ pkgconfig ];
- buildInputs = [ cmake sqlite systemd ] ++ stdenv.lib.optional tlsSupport openssl;
+ buildInputs = [ cmake sqlite systemd ] ++ lib.optional tlsSupport openssl;
outputs = [ "out"
"mod_example"
@@ -38,7 +38,7 @@ stdenv.mkDerivation rec {
${if tlsSupport then "-DSSL_SUPPORT=ON" else "-DSSL_SUPPORT=OFF"}
'';
- meta = with stdenv.lib; {
+ meta = with lib; {
description = "High performance peer-to-peer hub for the ADC network";
homepage = https://www.uhub.org/;
license = licenses.gpl3;