summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/uhub/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-12-04 21:24:48 +0100
committermakefu <github@syntax-fehler.de>2021-12-04 21:24:48 +0100
commit7ca789f598c856ceda3ac55d028ab5a8a8a1e6a2 (patch)
tree9793b82947801f39f55b393cd02951c25de26099 /makefu/5pkgs/uhub/default.nix
parent4f500d5006b9a1594589b60278515220ed4b75da (diff)
ma pkgs: stdenv.lib -> lib
Diffstat (limited to 'makefu/5pkgs/uhub/default.nix')
-rw-r--r--makefu/5pkgs/uhub/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/makefu/5pkgs/uhub/default.nix b/makefu/5pkgs/uhub/default.nix
index 66dfebc3..e0ee035e 100644
--- a/makefu/5pkgs/uhub/default.nix
+++ b/makefu/5pkgs/uhub/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchpatch, fetchFromGitHub, cmake, openssl, sqlite, pkgconfig, systemd
+{ stdenv, lib, fetchpatch, fetchFromGitHub, cmake, openssl, sqlite, pkgconfig, systemd
, tlsSupport ? false }:
assert tlsSupport -> openssl != null;
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
};
nativeBuildInputs = [ pkgconfig ];
- buildInputs = [ cmake sqlite systemd ] ++ stdenv.lib.optional tlsSupport openssl;
+ buildInputs = [ cmake sqlite systemd ] ++ lib.optional tlsSupport openssl;
outputs = [ "out"
"mod_example"
@@ -38,7 +38,7 @@ stdenv.mkDerivation rec {
${if tlsSupport then "-DSSL_SUPPORT=ON" else "-DSSL_SUPPORT=OFF"}
'';
- meta = with stdenv.lib; {
+ meta = with lib; {
description = "High performance peer-to-peer hub for the ADC network";
homepage = https://www.uhub.org/;
license = licenses.gpl3;