summaryrefslogtreecommitdiffstats
path: root/lib/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/shell.nix')
-rw-r--r--lib/shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/shell.nix b/lib/shell.nix
index a8ff5dbe..f9779028 100644
--- a/lib/shell.nix
+++ b/lib/shell.nix
@@ -5,7 +5,7 @@ with lib;
rec {
escape =
let
- isSafeChar = c: match "[-+./0-9:=A-Z_a-z]" c != null;
+ isSafeChar = testString "[-+./0-9:=A-Z_a-z]";
in
stringAsChars (c:
if isSafeChar c then c