summaryrefslogtreecommitdiffstats
path: root/lib/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-18 15:36:18 +0200
committertv <tv@krebsco.de>2017-06-18 15:49:54 +0200
commit9f75e81c5f91aa4236f86c29437de190503ad586 (patch)
tree44030457fe5589d2b7e090528d0e56cee88b5fa7 /lib/shell.nix
parentce89fd63d5d3ed3dc701b11a79d392294d35bd76 (diff)
lib: add test and testString
Diffstat (limited to 'lib/shell.nix')
-rw-r--r--lib/shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/shell.nix b/lib/shell.nix
index a8ff5dbe..f9779028 100644
--- a/lib/shell.nix
+++ b/lib/shell.nix
@@ -5,7 +5,7 @@ with lib;
rec {
escape =
let
- isSafeChar = c: match "[-+./0-9:=A-Z_a-z]" c != null;
+ isSafeChar = testString "[-+./0-9:=A-Z_a-z]";
in
stringAsChars (c:
if isSafeChar c then c