summaryrefslogtreecommitdiffstats
path: root/lass/2configs/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/zsh.nix')
-rw-r--r--lass/2configs/zsh.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/lass/2configs/zsh.nix b/lass/2configs/zsh.nix
index a7b0c372..f77aa258 100644
--- a/lass/2configs/zsh.nix
+++ b/lass/2configs/zsh.nix
@@ -51,6 +51,18 @@
#enable automatic rehashing of $PATH
zstyle ':completion:*' rehash true
+ # fancy mv which interactively gets the second argument if not given
+ function mv() {
+ if [[ "$#" -ne 1 ]] || [[ ! -e "$1" ]]; then
+ command mv -v "$@"
+ return
+ fi
+
+ newfilename="$1"
+ vared newfilename
+ command mv -v -- "$1" "$newfilename"
+ }
+
#beautiful colors
eval $(dircolors -b ${pkgs.fetchFromGitHub {
owner = "trapd00r";