summaryrefslogtreecommitdiffstats
path: root/lass/2configs/zsh.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-07-28 12:32:43 +0200
committerlassulus <git@lassul.us>2023-07-28 12:32:43 +0200
commitcbfcc890e3b76d942b927809bf981a5fa7289e6a (patch)
tree6886096a48089a6d80098650de41b64ff06f86c2 /lass/2configs/zsh.nix
parent447a000e0426e7356d65661425299c2406980126 (diff)
l yellow.r: migrate to airvpn
Diffstat (limited to 'lass/2configs/zsh.nix')
-rw-r--r--lass/2configs/zsh.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/lass/2configs/zsh.nix b/lass/2configs/zsh.nix
index a7b0c372..f77aa258 100644
--- a/lass/2configs/zsh.nix
+++ b/lass/2configs/zsh.nix
@@ -51,6 +51,18 @@
#enable automatic rehashing of $PATH
zstyle ':completion:*' rehash true
+ # fancy mv which interactively gets the second argument if not given
+ function mv() {
+ if [[ "$#" -ne 1 ]] || [[ ! -e "$1" ]]; then
+ command mv -v "$@"
+ return
+ fi
+
+ newfilename="$1"
+ vared newfilename
+ command mv -v -- "$1" "$newfilename"
+ }
+
#beautiful colors
eval $(dircolors -b ${pkgs.fetchFromGitHub {
owner = "trapd00r";