summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/influx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/influx.nix')
-rw-r--r--krebs/2configs/shack/influx.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/krebs/2configs/shack/influx.nix b/krebs/2configs/shack/influx.nix
new file mode 100644
index 00000000..599416c9
--- /dev/null
+++ b/krebs/2configs/shack/influx.nix
@@ -0,0 +1,18 @@
+let
+ port = 8086;
+in
+{
+ networking.firewall.allowedTCPPorts = [ port ]; # for legacy applications
+ services.nginx.virtualHosts."influx.shack" = {
+ locations."/" = {
+ proxyPass = "http://localhost:${toString port}/";
+ };
+ };
+ services.influxdb = {
+ enable = true;
+ extraConfig = {
+ bind-address = ":${toString port}";
+ http.log-enabled = false;
+ };
+ };
+}