summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/influx.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-07-19 16:04:45 +0200
committermakefu <github@syntax-fehler.de>2019-07-19 19:34:08 +0200
commit1eeccb54a2ca0a2451781c0d528a410dbffae3c2 (patch)
treeb012d116e7e02a5f2b69f04f3325069a9c85c797 /krebs/2configs/shack/influx.nix
parent124b1d7639c404e5a58a9aef0f0bee1424f54a45 (diff)
wolf.r: graphite.shack redirect to graphite:8080
Diffstat (limited to 'krebs/2configs/shack/influx.nix')
-rw-r--r--krebs/2configs/shack/influx.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/krebs/2configs/shack/influx.nix b/krebs/2configs/shack/influx.nix
new file mode 100644
index 00000000..599416c9
--- /dev/null
+++ b/krebs/2configs/shack/influx.nix
@@ -0,0 +1,18 @@
+let
+ port = 8086;
+in
+{
+ networking.firewall.allowedTCPPorts = [ port ]; # for legacy applications
+ services.nginx.virtualHosts."influx.shack" = {
+ locations."/" = {
+ proxyPass = "http://localhost:${toString port}/";
+ };
+ };
+ services.influxdb = {
+ enable = true;
+ extraConfig = {
+ bind-address = ":${toString port}";
+ http.log-enabled = false;
+ };
+ };
+}