summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix22
1 files changed, 12 insertions, 10 deletions
diff --git a/default.nix b/default.nix
index 841882f5..ff782e28 100644
--- a/default.nix
+++ b/default.nix
@@ -25,16 +25,18 @@ in with klib; let
kpkgs // upkgs;
};
- out =
- { inherit (eval {}) config options pkgs; } //
- lib.mapAttrs
- (name: _:
- if builtins.pathExists (nspath name "default.nix")
- then import (nspath name "default.nix")
- else import-1systems (nspath name "1systems"))
- (lib.filterAttrs
- (n: t: !lib.hasPrefix "." n && t == "directory")
- (builtins.readDir ./.));
+ out = {
+ inherit (eval {}) config options pkgs;
+ krebs = import ./krebs;
+ users = lib.mapAttrs
+ (name: _:
+ if builtins.pathExists (nspath name "default.nix")
+ then import (nspath name "default.nix")
+ else import-1systems (nspath name "1systems"))
+ (lib.filterAttrs
+ (n: t: !lib.hasPrefix "." n && t == "directory" && n != "krebs")
+ (builtins.readDir ./.));
+ };
eval = path: import <nixpkgs/nixos/lib/eval-config.nix> {
modules = [