summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-19 21:20:38 +0200
committertv <tv@shackspace.de>2015-10-19 21:20:38 +0200
commit5fdae43a99af8783549e8b7d1424556d1f219bf6 (patch)
treea27146bdc1049bb794b230b4cc1e0da833e34165 /default.nix
parentdc52c4b988ba1e64bf91567f06b89586ca92fa47 (diff)
move user namespaces into "users" attribute
IOW get ${user-name} -> get users.${user-name}
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix22
1 files changed, 12 insertions, 10 deletions
diff --git a/default.nix b/default.nix
index 841882f5..ff782e28 100644
--- a/default.nix
+++ b/default.nix
@@ -25,16 +25,18 @@ in with klib; let
kpkgs // upkgs;
};
- out =
- { inherit (eval {}) config options pkgs; } //
- lib.mapAttrs
- (name: _:
- if builtins.pathExists (nspath name "default.nix")
- then import (nspath name "default.nix")
- else import-1systems (nspath name "1systems"))
- (lib.filterAttrs
- (n: t: !lib.hasPrefix "." n && t == "directory")
- (builtins.readDir ./.));
+ out = {
+ inherit (eval {}) config options pkgs;
+ krebs = import ./krebs;
+ users = lib.mapAttrs
+ (name: _:
+ if builtins.pathExists (nspath name "default.nix")
+ then import (nspath name "default.nix")
+ else import-1systems (nspath name "1systems"))
+ (lib.filterAttrs
+ (n: t: !lib.hasPrefix "." n && t == "directory" && n != "krebs")
+ (builtins.readDir ./.));
+ };
eval = path: import <nixpkgs/nixos/lib/eval-config.nix> {
modules = [