summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/x220.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-02-15 14:00:47 +0100
committertv <tv@krebsco.de>2021-02-15 14:16:27 +0100
commite249b2d8d4c9368a911ac1d5d7492c14a9602c05 (patch)
treeadc8a3dfb6eaba35c397de4b014e5789e6a25158 /tv/2configs/hw/x220.nix
parentd2edb22d9f975959fc21a19f4e9da4a591d2b2a5 (diff)
tv config: define primary screens
Diffstat (limited to 'tv/2configs/hw/x220.nix')
-rw-r--r--tv/2configs/hw/x220.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/tv/2configs/hw/x220.nix b/tv/2configs/hw/x220.nix
index aadfc669..ecbb84a4 100644
--- a/tv/2configs/hw/x220.nix
+++ b/tv/2configs/hw/x220.nix
@@ -1,4 +1,6 @@
-{ config, pkgs, ... }:
+{ config, pkgs, ... }: let
+ lib = import <stockholm/lib>;
+in
{
imports = [
../smartd.nix
@@ -74,4 +76,7 @@
services.xserver = {
videoDriver = "intel";
};
+
+ tv.hw.screens.primary.width = lib.mkDefault 1366;
+ tv.hw.screens.primary.height = lib.mkDefault 768;
}