summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-30 04:27:25 +0200
committertv <tv@krebsco.de>2017-06-30 04:27:25 +0200
commit7d983f09c8433b623ffb49435807d3417a93776b (patch)
tree8fb5daeaafbf624bf837df0a6466d2805fd2bc54 /shell.nix
parent849d0ba98f03dc8700e6b9bb724b9afdbde68713 (diff)
shell: inline qtarget
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index 9cc74066..e16f172e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -62,8 +62,6 @@
export target_path="$(echo $target_object | ${pkgs.jq}/bin/jq -r .path)"
export target_local="$(echo $target_object | ${pkgs.jq}/bin/jq -r .local)"
- export qtarget="$target_user@$target_host:$target_port$target_path"
-
if \test "''${using_proxy-}" != true; then
${init.env.populate}
if \test "$target_local" != true; then
@@ -104,7 +102,9 @@
-I nixos-config="$config" \
-E 'with import <stockholm>; config.krebs.build.source' \
|
- ${spkgs.populate}/bin/populate "$qtarget" >&2
+ ${spkgs.populate}/bin/populate \
+ "$target_user@$target_host:$target_port$target_path" \
+ >&2
'';
proxy = pkgs.writeScript "init.env.proxy" /* sh */ ''
#! ${pkgs.dash}/bin/dash