summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-06 00:02:17 +0100
committertv <tv@krebsco.de>2017-12-06 00:02:17 +0100
commit7b38d1a8219ff7cfa39202ff17f1c92bd799c9b0 (patch)
tree2c43cdbd4ba1a3252f0a21be659cfa22f678e62a /shell.nix
parent289dd785e5bd5f3a628a7f0282ed4f8638277c5c (diff)
stockholm: drop OLD_PATH
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 6c6b7cad..bfdf1b3c 100644
--- a/shell.nix
+++ b/shell.nix
@@ -5,14 +5,13 @@ let
in pkgs.stdenv.mkDerivation {
name = "stockholm";
shellHook = /* sh */ ''
- export OLD_PATH="$PATH"
export NIX_PATH=stockholm=${toString ./.}:nixpkgs=${toString <nixpkgs>}
if test -e /nix/var/nix/daemon-socket/socket; then
export NIX_REMOTE=daemon
fi
export PATH=${lib.makeBinPath [
pkgs.stockholm
- ]}
+ ]}''${PATH+:$PATH}
eval "$(declare -F | ${pkgs.gnused}/bin/sed s/declare/unset/)"
shopt -u no_empty_cmd_completion