summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-05 23:25:09 +0100
committertv <tv@krebsco.de>2017-12-05 23:30:31 +0100
commit289dd785e5bd5f3a628a7f0282ed4f8638277c5c (patch)
tree59ab504a650fbde6406045f22e0fd2710c4fdbf0 /shell.nix
parent3fb25717c5c7dbe69f56cea4c529cac398789c2b (diff)
stockholm: export HOSTNAME and STOCKHOLM_VERSION
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/shell.nix b/shell.nix
index 69f5e86c..6c6b7cad 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,16 +2,6 @@ let
lib = import ./lib;
pkgs = import <nixpkgs> { overlays = [(import ./krebs/5pkgs)]; };
- get-version = pkgs.writeDash "get-version" ''
- set -efu
- version=git.$(${pkgs.git}/bin/git describe --always --dirty)
- case $version in (*-dirty)
- version=$version@$HOSTNAME
- esac
- date=$(${pkgs.coreutils}/bin/date +%y.%m)
- echo "$date.$version"
- '';
-
in pkgs.stdenv.mkDerivation {
name = "stockholm";
shellHook = /* sh */ ''
@@ -39,9 +29,6 @@ in pkgs.stdenv.mkDerivation {
:
}
- export HOSTNAME="$(${pkgs.nettools}/bin/hostname)"
- export STOCKHOLM_VERSION="''${STOCKHOLM_VERSION-$(${get-version})}"
-
PS1='\[\e[38;5;162m\]\w\[\e[0m\] '
'';
}