summaryrefslogtreecommitdiffstats
path: root/mb/3modules/hosts.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-04-19 16:14:53 +0200
committerlassulus <lassulus@lassul.us>2019-04-26 20:09:55 +0200
commitd5c580daa1c1fd878dad9f08ea699bc531791a08 (patch)
tree1f4f3f32f4079648e288ece2c610243de2771f8f /mb/3modules/hosts.nix
parent1acb5f9fd895fd8b241197ef309f9cc09c211719 (diff)
init mb
Diffstat (limited to 'mb/3modules/hosts.nix')
-rw-r--r--mb/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/mb/3modules/hosts.nix b/mb/3modules/hosts.nix
new file mode 100644
index 00000000..5dc9b5ca
--- /dev/null
+++ b/mb/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with import <stockholm/lib>;
+
+{
+ options.mb.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "mb" && host.ci)
+ config.krebs.hosts;
+ };
+}