summaryrefslogtreecommitdiffstats
path: root/mb/3modules/hosts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mb/3modules/hosts.nix')
-rw-r--r--mb/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/mb/3modules/hosts.nix b/mb/3modules/hosts.nix
new file mode 100644
index 00000000..5dc9b5ca
--- /dev/null
+++ b/mb/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with import <stockholm/lib>;
+
+{
+ options.mb.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "mb" && host.ci)
+ config.krebs.hosts;
+ };
+}