summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-09-07 15:52:18 +0200
committermakefu <github@syntax-fehler.de>2016-09-07 15:52:18 +0200
commit907499c10bd4063cd4649899b959edd503743ee7 (patch)
tree72730f68e15cf8494a777584175aa3f480312f02 /makefu/2configs/default.nix
parentdf48b1cce8982684177d3114760af107c2f76818 (diff)
m 2 default: remove trace, use || instead of or
Diffstat (limited to 'makefu/2configs/default.nix')
-rw-r--r--makefu/2configs/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/makefu/2configs/default.nix b/makefu/2configs/default.nix
index 110d1ec8..a7c2a983 100644
--- a/makefu/2configs/default.nix
+++ b/makefu/2configs/default.nix
@@ -22,9 +22,9 @@ with config.krebs.lib;
build = {
user = config.krebs.users.makefu;
source = let inherit (config.krebs.build) host user; in {
- nixpkgs = if config.makefu.full-populate or (getEnv "dummy_secrets" == "true") then
+ nixpkgs = if config.makefu.full-populate || (getEnv "dummy_secrets" == "true") then
{ # stable @ 2016-07-20
- git = trace "Populating nixpkgs via full clone" { url = https://github.com/nixos/nixpkgs; ref = "125ffff"; };
+ git = { url = https://github.com/nixos/nixpkgs; ref = "125ffff"; };
}
else
# TODO use http, once it is implemented
@@ -32,7 +32,7 @@ with config.krebs.lib;
## prepare so we do not have to wait for rsync:
## cd /var/src; curl https://github.com/nixos/nixpkgs/tarball/125ffff -L | tar zx && mv NixOS-nixpkgs-125ffff nixpkgs
- trace "Populating nixpkgs with local directory" { file = "/home/makefu/store/125ffff";};
+ { file = "/home/makefu/store/125ffff";};
secrets.file =
if getEnv "dummy_secrets" == "true"
then toString <stockholm/makefu/6tests/data/secrets>