summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-14 19:15:56 +0200
committertv <tv@shackspace.de>2015-06-14 19:15:56 +0200
commit8ee650ed25eb7b3f879b97b66d38a57bc6439ed7 (patch)
tree7bb93a9238a4d7ccd55ffa64680c8dcffbddf1d0 /lib/default.nix
parentdba033ed10838c9ff8c1720d41f8845c5199927e (diff)
modules/tv/git: initial commit (incl. lib.git)
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 26653d96..27cf0e25 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -3,10 +3,20 @@
with builtins;
let
- inherit (lib) stringAsChars;
+ inherit (lib) mapAttrs stringAsChars;
in
-{
+rec {
+ git = import ./git.nix {
+ lib = lib // {
+ inherit addNames;
+ };
+ };
+
+ addName = name: set:
+ set // { inherit name; };
+
+ addNames = mapAttrs addName;
# "7.4.335" -> "74"