summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-14 18:48:53 +0200
committertv <tv@shackspace.de>2015-06-14 18:48:53 +0200
commitdba033ed10838c9ff8c1720d41f8845c5199927e (patch)
treee685dbe1c30a47e6e0390bc7fbc5b5ce75652908 /lib/default.nix
parent390e1f6650e4302746d215922f4c1ddccd96ea59 (diff)
lib: take lib instead of pkgs argument
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 995e3dbc..26653d96 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -1,16 +1,16 @@
-{ pkgs, ... }:
+{ lib, ... }:
with builtins;
let
- inherit (pkgs.lib) stringAsChars;
+ inherit (lib) stringAsChars;
in
{
# "7.4.335" -> "74"
- majmin = with pkgs.lib; x : concatStrings (take 2 (splitString "." x));
+ majmin = with lib; x : concatStrings (take 2 (splitString "." x));
concat = xs :