summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/flameshot-once/profile.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-04-28 14:18:00 +0200
committerlassulus <lassulus@lassul.us>2019-04-28 14:18:00 +0200
commit915e4b843790d3e71bdccea124d4832ca042e456 (patch)
treea375c5be89afe8ff04ffa4f1e45c8bcd388590af /krebs/5pkgs/simple/flameshot-once/profile.nix
parent710609af31b72abf805370f3fe322daa41c1a55b (diff)
parent73e89ece549bad03d97326cc94e9ba59a762d298 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'krebs/5pkgs/simple/flameshot-once/profile.nix')
-rw-r--r--krebs/5pkgs/simple/flameshot-once/profile.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/krebs/5pkgs/simple/flameshot-once/profile.nix b/krebs/5pkgs/simple/flameshot-once/profile.nix
index 7373da00..8ea8a850 100644
--- a/krebs/5pkgs/simple/flameshot-once/profile.nix
+++ b/krebs/5pkgs/simple/flameshot-once/profile.nix
@@ -29,7 +29,7 @@ let
eval = evalModules {
modules = singleton {
- _file = toString ./config.nix;
+ _file = toString ./profile.nix;
imports = singleton config;
options = {
buttons = mkOption {
@@ -77,6 +77,14 @@ let
default = false;
type = types.bool;
};
+ timeout = mkOption {
+ default = 100;
+ description = ''
+ Maximum time in milliseconds allowed for the flameshot daemon to
+ react.
+ '';
+ type = types.positive;
+ };
};
};
};
@@ -125,5 +133,6 @@ in
pkgs.writeDash "flameshot.profile" ''
export FLAMESHOT_CAPTURE_PATH=${cfg.savePath}
+ export FLAMESHOT_ONCE_TIMEOUT=${toString cfg.timeout}
export XDG_CONFIG_HOME=${XDG_CONFIG_HOME}
''