summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/flameshot-once/profile.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/flameshot-once/profile.nix')
-rw-r--r--krebs/5pkgs/simple/flameshot-once/profile.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/krebs/5pkgs/simple/flameshot-once/profile.nix b/krebs/5pkgs/simple/flameshot-once/profile.nix
index 7373da00..8ea8a850 100644
--- a/krebs/5pkgs/simple/flameshot-once/profile.nix
+++ b/krebs/5pkgs/simple/flameshot-once/profile.nix
@@ -29,7 +29,7 @@ let
eval = evalModules {
modules = singleton {
- _file = toString ./config.nix;
+ _file = toString ./profile.nix;
imports = singleton config;
options = {
buttons = mkOption {
@@ -77,6 +77,14 @@ let
default = false;
type = types.bool;
};
+ timeout = mkOption {
+ default = 100;
+ description = ''
+ Maximum time in milliseconds allowed for the flameshot daemon to
+ react.
+ '';
+ type = types.positive;
+ };
};
};
};
@@ -125,5 +133,6 @@ in
pkgs.writeDash "flameshot.profile" ''
export FLAMESHOT_CAPTURE_PATH=${cfg.savePath}
+ export FLAMESHOT_ONCE_TIMEOUT=${toString cfg.timeout}
export XDG_CONFIG_HOME=${XDG_CONFIG_HOME}
''