summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/email-header.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-24 01:57:28 +0200
committertv <tv@krebsco.de>2017-05-24 01:57:28 +0200
commiteae210f8ff05b7f59ab62ba161c86971dbd7f50e (patch)
tree037d7ad582303b21230a323c2e3e500ed454c911 /krebs/5pkgs/haskell/email-header.nix
parent17df5f0c453d891b29dbb6a9d189fc8dcf88fac0 (diff)
krebs/5pkgs: move haskell stuff to a subdir
Diffstat (limited to 'krebs/5pkgs/haskell/email-header.nix')
-rw-r--r--krebs/5pkgs/haskell/email-header.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/email-header.nix b/krebs/5pkgs/haskell/email-header.nix
new file mode 100644
index 00000000..b5424080
--- /dev/null
+++ b/krebs/5pkgs/haskell/email-header.nix
@@ -0,0 +1,25 @@
+{ mkDerivation, attoparsec, base, base64-bytestring, bytestring
+, case-insensitive, containers, exceptions, fetchgit, QuickCheck
+, stdenv, tasty, tasty-quickcheck, text, text-icu, time
+}:
+mkDerivation {
+ pname = "email-header";
+ version = "0.3.0";
+ src = fetchgit {
+ url = "https://github.com/4z3/email-header";
+ rev = "7b179bd31192ead8afe7a0b6e34bcad4039deaa8";
+ sha256 = "12j2n3sbvzjnw99gga7kkdygm8n3qx2lh8q26ad6a53xm5whnz59";
+ };
+ buildDepends = [
+ attoparsec base base64-bytestring bytestring case-insensitive
+ containers exceptions text text-icu time
+ ];
+ testDepends = [
+ base bytestring case-insensitive containers QuickCheck tasty
+ tasty-quickcheck text time
+ ];
+ jailbreak = true;
+ homepage = "http://github.com/knrafto/email-header";
+ description = "Parsing and rendering of email and MIME headers";
+ license = stdenv.lib.licenses.bsd3;
+}