summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/monit.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-03-07 19:25:03 +0100
committerlassulus <lass@lassul.us>2017-03-07 19:25:03 +0100
commit5fe56a99b806335698354c2c6c5a6cd9c3f28749 (patch)
treed73e979e9a1fc44a00e64366705eecc04e918f54 /krebs/3modules/monit.nix
parentfd6c056a720544319f02cf02b64fa8dd2b657aa8 (diff)
k 3 monit: allow path or str for alarms & test
Diffstat (limited to 'krebs/3modules/monit.nix')
-rw-r--r--krebs/3modules/monit.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/krebs/3modules/monit.nix b/krebs/3modules/monit.nix
index 4d4066ae..cc4a1b20 100644
--- a/krebs/3modules/monit.nix
+++ b/krebs/3modules/monit.nix
@@ -49,10 +49,10 @@ let
type = with types; attrsOf (submodule {
options = {
test = mkOption {
- type = path;
+ type = either path str;
};
alarm = mkOption {
- type = path;
+ type = either path str;
};
interval = mkOption {
type = str;