summaryrefslogtreecommitdiffstats
path: root/tv/1systems/xu-qemu0.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/1systems/xu-qemu0.nix')
-rw-r--r--tv/1systems/xu-qemu0.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/tv/1systems/xu-qemu0.nix b/tv/1systems/xu-qemu0.nix
new file mode 100644
index 00000000..03ac19cf
--- /dev/null
+++ b/tv/1systems/xu-qemu0.nix
@@ -0,0 +1,27 @@
+{ config, lib, pkgs, ... }:
+
+{
+ krebs.hosts.xu-qemu0 = {
+ cores = 1;
+ ssh.privkey.path = <secrets/ssh.id_ed25519>;
+ # cannot define ssh.pubkey without at least one addr or alias
+ #ssh.pubkey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFe51rD0ZqlMXNi/YpapnRzvdzCjI0icmxfCyBLSKG04";
+ };
+ krebs.build.host = config.krebs.hosts.xu-qemu0;
+
+ imports = [
+ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ ];
+
+ boot.loader.grub.device = "/dev/sda";
+
+ fileSystems = {
+ "/boot" = {
+ device = "/dev/sda1";
+ };
+ "/" = {
+ device = "/dev/sda2";
+ fsType = "btrfs";
+ };
+ };
+}