summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/uwsgi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/uwsgi.nix')
-rw-r--r--makefu/2configs/deployment/uwsgi.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/makefu/2configs/deployment/uwsgi.nix b/makefu/2configs/deployment/uwsgi.nix
new file mode 100644
index 00000000..4ad9961f
--- /dev/null
+++ b/makefu/2configs/deployment/uwsgi.nix
@@ -0,0 +1,16 @@
+{ config, lib, pkgs, ... }:
+# more than just nginx config but not enough to become a module
+with import <stockholm/lib>;
+let
+ external-ip = config.krebs.build.host.nets.internet.ip4.addr;
+ wsgi-sock = "${config.services.uwsgi.runDir}/uwsgi.sock";
+ elch-sock = "${config.services.uwsgi.runDir}/uwsgi-elch.sock";
+in {
+
+ services.uwsgi = {
+ enable = true;
+ user = "nginx";
+ plugins = [ "python2" ];
+ instance.type = "emperor";
+ };
+}