summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/base-gui.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/base-gui.nix')
-rw-r--r--makefu/2configs/base-gui.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/makefu/2configs/base-gui.nix b/makefu/2configs/base-gui.nix
new file mode 100644
index 00000000..4e5558a1
--- /dev/null
+++ b/makefu/2configs/base-gui.nix
@@ -0,0 +1,57 @@
+{ config, lib, pkgs, ... }:
+##
+# of course this name is a lie - it prepares a GUI environment close to my
+# current configuration.
+#
+# autologin with mainUser into awesome
+##
+#
+with lib;
+let
+ mainUser = config.krebs.build.user.name;
+in
+{
+ imports = [ ];
+ services.xserver = {
+ enable = true;
+ layout = "us";
+ xkbVariant = "altgr-intl";
+ xkbOptions = "ctrl:nocaps";
+
+ windowManager = {
+ awesome.enable = true;
+ awesome.luaModules = [ pkgs.luaPackages.vicious ];
+ default = "awesome";
+ };
+
+ displayManager.auto.enable = true;
+ displayManager.auto.user = mainUser;
+ desktopManager.xterm.enable = false;
+ };
+
+## FONTS
+# TODO: somewhere else?
+
+ i18n.consoleFont = "Lat2-Terminus16";
+
+ fonts = {
+ enableCoreFonts = true;
+ enableFontDir = true;
+ enableGhostscriptFonts = false;
+ fonts = [ pkgs.terminus_font ];
+ };
+
+ environment.systemPackages = with pkgs;[
+ xlockmore
+ rxvt_unicode-with-plugins
+ vlc
+ firefox
+ chromium
+ ];
+ # TODO: use mainUser
+ users.extraUsers.makefu.extraGroups = [ "audio" ];
+ hardware.pulseaudio = {
+ enable = true;
+ # systemWide = true;
+ };
+}