summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/vbob.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/vbob.nix')
-rw-r--r--makefu/1systems/vbob.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/makefu/1systems/vbob.nix b/makefu/1systems/vbob.nix
index 4d8e8ced..b121a730 100644
--- a/makefu/1systems/vbob.nix
+++ b/makefu/1systems/vbob.nix
@@ -1,7 +1,7 @@
#
#
#
-{ config, pkgs, ... }:
+{ lib, config, pkgs, ... }:
{
krebs.build.host = config.krebs.hosts.vbob;
@@ -12,13 +12,21 @@
../2configs/main-laptop.nix #< base-gui
# environment
+
../2configs/zsh-user.nix
../2configs/virtualization.nix
];
+
+ # allow vbob to deploy self
+ users.extraUsers = {
+ root = {
+ openssh.authorizedKeys.keys = [ config.krebs.users.makefu-vbob.pubkey ];
+ };
+ };
nixpkgs.config.packageOverrides = pkgs: { tinc = pkgs.tinc_pre; };
environment.systemPackages = with pkgs;[
get
- ];
+ ];
networking.firewall.allowedTCPPorts = [
25